今天是: 收藏本站 设为主页

JS代码解决IE6-IE8的兼容性问题

日期:2012-03-07  点击率:839


一段JS调用解决IE6-IE8的兼容性问题

  今天在网上学到一招分享给大家,由于目前IE6.0还是最主流的浏览器,我用了也好多年了,一直是IE6配合遨游一起用,所以做出来的东西经常会在IE7及以上的浏览器里面显示不好,今天发现一个绝招,虽然还没有使用,不过看着很强大,和大家分享一下。

  如果是IE7

以下是代码片段:
<!–[ifltIE7]>
<scriptsrcscriptsrc=”http://ie7-js.googlecode.com/svn/version/2.0(beta3)/IE7.js”type=”text/javascript”></script>
<![endif]–>


  如果是IE8

以下是代码片段:
<!–[ifltIE8]>
<scriptsrcscriptsrc=”http://ie7-js.googlecode.com/svn/version/2.0(beta3)/IE8.js”type=”text/javascript”></script>
<![endif]–>


  简单吧,大家可能看出来了。这是调用的一个在GoogleCode上的项目,速度快又不占用您的带宽,不错吧?

  注意:如果您想支持IE全系列的话,用IE8的那个就可以了,不用重复的加上IE7的那段代码了。想知道到底它目前支持哪些兼容参数的话,您可以移步浏览这里查阅,希望我的这篇文章对你有帮助。




下一篇:导出excel时防止科学计数法的解决方案    上一篇:基于 OpenSSL 的 CA 建立及证书签发